You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
calamares-packaging/debian/rules

17 lines
517 B

#!/usr/bin/make -f
# Hardening options, see: https://wiki.debian.org/Hardening
export DEB_BUILD_MAINT_OPTIONS=hardening=+all
# Help makes build paths reproducible
export DEB_BUILD_MAINT_OPTIONS=buildinfo=+path
%:
dh $@ --with kf6 --buildsystem kf6
override_dh_auto_configure:
dh_auto_configure -- -DKDE_INSTALL_USE_QT_SYS_PATHS=ON -DBUILD_APPDATA=ON -DBUILD_APPSTREAM=ON -DINSTALL_COMPLETION=ON -DWITH_QT6=ON
# Some test don't work well, we don't need to run them at package build time.
override_dh_auto_test: