You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
libfm-qt-packaging/debian/patches/fix-smb-recursive-copy.patch

37 lines
1.7 KiB

From 6cb5f38d2c1261b782b16da45bb323b069db94fe Mon Sep 17 00:00:00 2001
From: Tsu Jan <tsujan2000@gmail.com>
Date: Mon, 8 Apr 2019 07:13:09 +0430
Subject: [PATCH] Fixed SMB recursive copy
Fixes https://github.com/lxqt/libfm-qt/issues/385 by trying to set dir permissions only once and ignoring possible errors (that happen with SMB and, maybe, other protocols).
---
src/core/filetransferjob.cpp | 9 +++++----
1 file changed, 5 insertions(+), 4 deletions(-)
diff --git a/src/core/filetransferjob.cpp b/src/core/filetransferjob.cpp
index 4039c58..6b44576 100644
--- a/src/core/filetransferjob.cpp
+++ b/src/core/filetransferjob.cpp
@@ -279,16 +279,17 @@ bool FileTransferJob::makeDir(const FilePath& srcPath, GFileInfoPtr srcInfo, Fil
mode, G_FILE_QUERY_INFO_NOFOLLOW_SYMLINKS,
cancellable().get(), &err);
if(!chmod_done) {
- ErrorAction act = emitError(err, ErrorSeverity::MODERATE);
+ /* NOTE: Some filesystems may not support this. So, ignore errors for now. */
+ break;
+ /*ErrorAction act = emitError(err, ErrorSeverity::MODERATE);
if(act != ErrorAction::RETRY) {
break;
- }
- /* FIXME: some filesystems may not support this. */
+ }*/
}
} while(!chmod_done && !isCancelled());
}
}
- return mkdir_done && chmod_done;
+ return mkdir_done/* && chmod_done*/;
}
bool FileTransferJob::handleError(GErrorPtr &err, const FilePath &srcPath, const GFileInfoPtr &srcInfo, FilePath &destPath, int& flags) {