You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
liblxqt-packaging/debian/rules

28 lines
573 B

#!/usr/bin/make -f
# export DH_VERBOSE=1
export LC_ALL=C.UTF-8
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
WHICH_OS := $(shell dpkg-architecture -qDEB_HOST_ARCH_OS 2>/dev/null)
ifeq ($(WHICH_OS), hurd)
NOT_LINUX := -DBUILD_BACKLIGHT_LINUX_BACKEND=NO
endif
ifeq ($(WHICH_OS), kfreebsd)
NOT_LINUX := -DBUILD_BACKLIGHT_LINUX_BACKEND=NO
endif
%:
dh ${@} --buildsystem cmake
override_dh_missing:
dh_missing --fail-missing
override_dh_auto_configure:
dh_auto_configure -- \
-DUPDATE_TRANSLATIONS=OFF \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
$(NOT_LINUX)