You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
libqtxdg-packaging/debian/rules

19 lines
363 B

#!/usr/bin/make -f
#export DH_VERBOSE = 1
export LC_ALL=C.UTF-8
export DEB_BUILD_MAINT_OPTIONS = hardening=+all optimize=+lto
%:
dh ${@} --buildsystem cmake
override_dh_missing:
dh_missing --fail-missing
override_dh_auto_configure:
dh_auto_configure -- \
-DBUILD_DEV_UTILS=YES \
-DCMAKE_BUILD_RPATH_USE_ORIGIN=ON \
-DCMAKE_BUILD_TYPE=RelWithDebInfo