You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
23 lines
803 B
23 lines
803 B
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -3,7 +3,7 @@
|
|
project(libsysstat)
|
|
|
|
# Set default installation paths
|
|
-set(LIB_INSTALL_DIR "lib${LIB_SUFFIX}" CACHE PATH "Installation path for libraries")
|
|
+set(LIB_INSTALL_DIR "${CMAKE_INSTALL_LIBDIR}" CACHE PATH "Installation path for libraries")
|
|
set(INCLUDE_INSTALL_DIR include CACHE PATH "Installation path for includes")
|
|
|
|
set(MAJOR_VERSION 0)
|
|
--- a/cmake/create_pkgconfig_file.cmake
|
|
+++ b/cmake/create_pkgconfig_file.cmake
|
|
@@ -28,7 +28,7 @@
|
|
if(${CMAKE_SYSTEM_NAME} STREQUAL "FreeBSD")
|
|
install(FILES ${_pkgfname} DESTINATION libdata/pkgconfig)
|
|
else()
|
|
- install(FILES ${_pkgfname} DESTINATION lib${LIB_SUFFIX}/pkgconfig)
|
|
+ install(FILES ${_pkgfname} DESTINATION ${LIB_INSTALL_DIR}/pkgconfig)
|
|
endif()
|
|
|
|
endmacro()
|