You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
26 lines
1014 B
26 lines
1014 B
From: Dmitry Shachnev <mitya57@debian.org>
|
|
Date: Sat, 19 Mar 2022 20:01:20 +0300
|
|
Subject: Replace gunixconnection.h file in gio-unix include dir check
|
|
|
|
That file was moved from gio-unix to gio in GLib 2.71.1:
|
|
https://gitlab.gnome.org/GNOME/glib/-/commit/83d45c4f35dc87ba
|
|
|
|
Forwarded: https://github.com/lxqt/lxqt-build-tools/pull/74
|
|
---
|
|
cmake/find-modules/FindGLIB.cmake | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/cmake/find-modules/FindGLIB.cmake b/cmake/find-modules/FindGLIB.cmake
|
|
index 0564b8d..bb2336a 100644
|
|
--- a/cmake/find-modules/FindGLIB.cmake
|
|
+++ b/cmake/find-modules/FindGLIB.cmake
|
|
@@ -101,7 +101,7 @@ foreach (_component ${GLIB_FIND_COMPONENTS})
|
|
elseif (${_component} STREQUAL "gio-unix")
|
|
pkg_check_modules(GIO_UNIX gio-unix-2.0)
|
|
find_path(GLIB_GIO_UNIX_INCLUDE_DIR
|
|
- NAMES gio/gunixconnection.h
|
|
+ NAMES gio/gunixfdlist.h
|
|
HINTS ${GIO_UNIX_INCLUDEDIR}
|
|
PATH_SUFFIXES gio-unix-2.0)
|
|
|