You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
lxqt-session-packaging/debian/rules

23 lines
494 B

#!/usr/bin/make -f
# export DH_VERBOSE=1
DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
export LC_ALL=C.UTF-8
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
ifeq ($(DEB_HOST_ARCH_OS),linux)
CMAKE_ARGS += -DWITH_LIBUDEV=ON
else
CMAKE_ARGS += -DWITH_LIBUDEV=OFF
endif
%:
dh ${@} --buildsystem cmake
override_dh_auto_configure:
dh_auto_configure -- \
-DPULL_TRANSLATIONS=OFF \
-DUPDATE_TRANSLATIONS=OFF \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
$(CMAKE_ARGS)