You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
37 lines
1.3 KiB
37 lines
1.3 KiB
From 3653bb1a1fcfd04da0d1c90dd588c0c067d72db1 Mon Sep 17 00:00:00 2001
|
|
From: Palo Kisa <palo.kisa@gmail.com>
|
|
Date: Wed, 22 Nov 2017 08:06:48 +0100
|
|
Subject: [PATCH] startlxqt: Add /usr/share & /etc into XDG_CONFIG_DIRS
|
|
|
|
---
|
|
CMakeLists.txt | 1 +
|
|
startlxqt.in | 2 +-
|
|
2 files changed, 2 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index 3cd4112..b9fd3d1 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -57,6 +57,7 @@ if(NOT("${LXQT_DATA_DIR}" MATCHES "^/usr(/local)?/share$"))
|
|
set(PREDEF_XDG_DATA_DIRS "${PREDEF_XDG_DATA_DIRS}:${LXQT_DATA_DIR}")
|
|
endif()
|
|
set(PREDEF_XDG_DATA_DIRS "${PREDEF_XDG_DATA_DIRS}:/usr/local/share:/usr/share")
|
|
+set(PREDEF_XDG_CONFIG_DIRS "/etc:${LXQT_ETC_XDG_DIR}:/usr/share")
|
|
configure_file(startlxqt.in startlxqt @ONLY)
|
|
install(PROGRAMS
|
|
"${CMAKE_CURRENT_BINARY_DIR}/startlxqt"
|
|
diff --git a/startlxqt.in b/startlxqt.in
|
|
index 02ef0c2..ae0569e 100755
|
|
--- a/startlxqt.in
|
|
+++ b/startlxqt.in
|
|
@@ -24,7 +24,7 @@ fi
|
|
export XDG_DATA_DIRS
|
|
|
|
if [ -z "$XDG_CONFIG_DIRS" ]; then
|
|
- export XDG_CONFIG_DIRS="@LXQT_ETC_XDG_DIR@"
|
|
+ export XDG_CONFIG_DIRS="@PREDEF_XDG_CONFIG_DIRS@"
|
|
else
|
|
if ! contains "$XDG_CONFIG_DIRS" '@LXQT_ETC_XDG_DIR@'; then
|
|
XDG_CONFIG_DIRS="$XDG_CONFIG_DIRS:@LXQT_ETC_XDG_DIR@"
|
|
|