You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
40 lines
1.2 KiB
40 lines
1.2 KiB
Description: Add some appdata
|
|
Author: Alf Gaida <agaida@siduction.org>
|
|
Last-Update: 2018-07-10
|
|
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -213,7 +213,7 @@ install(FILES
|
|
|
|
install(FILES
|
|
qterminal.appdata.xml
|
|
- DESTINATION "${CMAKE_INSTALL_DATADIR}/appdata"
|
|
+ DESTINATION "${CMAKE_INSTALL_DATADIR}/metainfo"
|
|
)
|
|
|
|
if(NOT APPLEBUNDLE)
|
|
--- a/qterminal.appdata.xml
|
|
+++ b/qterminal.appdata.xml
|
|
@@ -1,6 +1,6 @@
|
|
<?xml version="1.0" encoding="UTF-8"?>
|
|
-<application>
|
|
- <id type="desktop">qterminal.desktop</id>
|
|
+<component type="desktop">
|
|
+ <id>qterminal.desktop</id>
|
|
<metadata_license>CC0-1.0</metadata_license>
|
|
<project_license>GPL-2</project_license>
|
|
<name>QTerminal</name>
|
|
@@ -39,5 +39,10 @@
|
|
<caption>Find bar and highlighted match.</caption>
|
|
</screenshot>
|
|
</screenshots>
|
|
- <url type="homepage">https://github.com/lxqt/qterminal</url>
|
|
-</application>
|
|
+
|
|
+ <developer_name>LXQt Team</developer_name>
|
|
+ <url type="homepage">https://github.com/lxde/qterminal</url>
|
|
+ <url type="bugtracker">https://github.com/qterminal/issues</url>
|
|
+ <url type="help">https://github.com/lxde/lxqt/wiki</url>
|
|
+ <url type="translate">http://github.com/lxde/lxqt-l10n</url>
|
|
+</component>
|