You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
80 lines
2.6 KiB
80 lines
2.6 KiB
Description: <short description, required>
|
|
<long description that can span multiple lines, optional>
|
|
Author: <name and email of author, optional>
|
|
Origin: <upstream|backport|vendor|other>, <URL, required except if Author is present>
|
|
Bug: <URL to the upstream bug report if any, implies patch has been forwarded, optional>
|
|
Bug-<Vendor>: <URL to the vendor bug report if any, optional>
|
|
Forwarded: <URL|no|not-needed, useless if you have a Bug field, optional>
|
|
Applied-Upstream: <version|URL|commit, identifies patches merged upstream, optional>
|
|
Reviewed-by: <name and email of a reviewer, optional>
|
|
Last-Update: 2023-11-17 <YYYY-MM-DD, last update of the meta-information, optional>
|
|
---
|
|
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
|
|
--- a/bin/qtls-translate
|
|
+++ b/bin/qtls-translate
|
|
@@ -35,26 +35,29 @@
|
|
#
|
|
# Update translation files.
|
|
#===============================================================================
|
|
-function usage
|
|
-{
|
|
+
|
|
+usage() {
|
|
printf "\nUse: lxqt-transupdate [source directory]\n"
|
|
exit 0
|
|
}
|
|
|
|
-function lxqt_transupdate
|
|
-{
|
|
- if [ "$1" == "-h" ] || [ "$1" == "--help" ]; then usage; fi
|
|
+lxqt_transupdate() {
|
|
+ if [ "$1" = "-h" ] || [ "$1" = "--help" ]; then
|
|
+ usage
|
|
+ fi
|
|
|
|
# Test for supported Qt version
|
|
- local qtVersion_=$(qmake -query QT_VERSION|cut -d'.' -f1)
|
|
- local qVersions_=(5 6)
|
|
+ local qtVersion_=$(qmake -query QT_VERSION | cut -d'.' -f1)
|
|
+ local qVersions_="5 6"
|
|
|
|
- if echo "${qVersions_[@]}" | grep -qw "$qtVersion_"; then supported_=1; fi
|
|
+ case $qVersions_ in
|
|
+ *"$qtVersion_"*) supported_=1 ;;
|
|
+ esac
|
|
|
|
if [ -z "$supported_" ]; then
|
|
printf "\nError: Qt%s is not supported. (Supported versions are: " "$qtVersion_"
|
|
- printf "%s" "${qVersions_[0]}"
|
|
- printf ", %s" "${qVersions_[@]:1}"
|
|
+ printf "%s" "${qVersions_%% *}"
|
|
+ printf ", %s" "${qVersions_#* }"
|
|
printf ')\n\n'
|
|
exit 1
|
|
fi
|
|
@@ -62,11 +65,15 @@ function lxqt_transupdate
|
|
local sourcedir_=
|
|
local templates_=$(find . -name \*.ts | grep -v '_')
|
|
|
|
- if [ -d "$1" ]; then sourcedir_="$1"; fi
|
|
+ if [ -d "$1" ]; then
|
|
+ sourcedir_="$1"
|
|
+ fi
|
|
|
|
for i in $templates_; do
|
|
- local transdir_=$(dirname $i)
|
|
- if [ "$sourcedir_" == "" ]; then sourcedir_=$(dirname $transdir_); fi
|
|
+ local transdir_=$(dirname "$i")
|
|
+ if [ "$sourcedir_" = "" ]; then
|
|
+ sourcedir_=$(dirname "$transdir_")
|
|
+ fi
|
|
local cmdUpdateTemplate="lupdate $sourcedir_ -ts $i -locations absolute -no-obsolete"
|
|
local cmdUpdateLanguage="lupdate $sourcedir_ -ts $transdir_/*_*.ts -locations absolute -no-obsolete"
|
|
|
|
@@ -79,4 +86,5 @@ function lxqt_transupdate
|
|
printf "\n"
|
|
done
|
|
}
|
|
+
|
|
lxqt_transupdate "${@}"
|