You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
screengrab-packaging/debian/rules

17 lines
352 B

#!/usr/bin/make -f
#export DH_VERBOSE=1
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
export LC_ALL=C.UTF-8
%:
dh ${@} --buildsystem=cmake
override_dh_auto_configure:
dh_auto_configure -- \
-DSG_DBUS_NOTIFY=ON \
-DSG_EXT_EDIT=ON \
-DSG_GLOBALSHORTCUTS=OFF \
-DUPDATE_TRANSLATIONS=OFF \
-DCMAKE_BUILD_TYPE=RelWithDebInfo