You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
trojita-packaging/debian/rules

34 lines
779 B

#!/usr/bin/make -f
# export DH_VERBOSE=1
INST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed -pthread
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
export LC_ALL=C.UTF-8
%:
dh ${@} --buildsystem cmake
override_dh_missing:
dh_missing --fail-missing
override_dh_auto_configure:
dh_auto_configure -- \
-DCMAKE_INSTALL_RPATH="/usr/lib/$(INST_ARCH)/trojita" \
-DWITH_DESKTOP=ON \
-DWITH_DBUS=ON \
-DWITH_RAGEL=ON \
-DWITH_ZLIB=ON \
-DWITH_SHARED_PLUGINS=ON \
-DWITH_TESTS=OFF \
-DWITH_MIMETIC=ON \
-DWITH_GPGMEPP=ON \
-DWITH_ABOOKADDRESSBOOK_PLUGIN=ON \
-DWITH_CLEARTEXT_PLUGIN=ON \
-DWITH_QTKEYCHAIN_PLUGIN=ON \
-DWITH_CRYPTO_MESSAGES=ON
override_dh_auto_test:
dh_auto_test || return 0