Alf Gaida e382624fd2 Cherry-picking upstream release 0.7.0
* Sync debian foo with experimental
* Bumped compat to 10
* Removed --parallel from rules, standard compat 10
* Bumped Standards to 3.9.8, no changes needed
* Bumped minimum version debhelper (>= 10)
* Bumped minimum version libqtermwidget5-0-dev (>= 0.7.0)
* Added build dependency libkf5windowsystem-dev
* Added build dependency liblxqt0-dev (>= 0.11.0)
* Added build dependency libqt5svg5-dev
* Added build dependency libqt5xdg-dev (>= 3.0.0)
* Added Recommends qterminal-l10n
* Fixed VCS fields, using https, plain /git/ and pointing to the right branch
* Fixed copyright Format field, using https
* Exported LC_ALL=C.UTF-8, make builds reproducible
* Added hardening options
* Added translation control to rules
* Set CMAKE_BUILD_TYPE=RelWithDebInfo
2016-10-18 20:59:44 +02:00

16 lines
339 B
Makefile
Executable File

#!/usr/bin/make -f
# export DH_VERBOSE=1
export LC_ALL=C.UTF-8
export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
%:
dh ${@} --buildsystem cmake
override_dh_auto_configure:
dh_auto_configure --\
-DPULL_TRANSLATIONS=OFF\
-DUPDATE_TRANSLATIONS=OFF\
-DCMAKE_BUILD_TYPE=RelWithDebInfo